Client Crash Report [#895828154]

Please describe what you were doing when the error occured:

Full critical error message, if available (including system info, message text and the history chain):

No Label

OS: Windows 10 (Version: 10.0; Build: 22621)
CPU: GenuineIntel @ 2615 MHz with 16087MB RAM
Video: No Video

Can't find 'ini:Engine.Engine.GameEngine' in configuration file

History: UObject::SafeLoadError <- UObject::StaticLoadClass <- InitEngine


Client version:
0.7.2-136-g202ed3a

It’s happen when I start the game.

Does it happen every time when you start the game?

If so, can you try starting the game in the safe mode once and then restarting the game again?

It happen everytime when i click on “Start”,

I try with Safe mode still the same error

Do you have anything in your Documents\My Games\Ymirheim\Option folder? Can you try deleting it?

Hmm I don’t have Option folder :l

Was it working before or is this a new installation?

Can you try deleting the System folder in of your game client (you can find the path in the launcher’s settings) and repair game files?

Yes, it was working on my previous computer and i bought a new one.

Ok i’m going to try

Did you move your documents folder to a different location by any chance? Or do you have any special characters (non-alphanumeric) in your Windows username?

I moved the files, but it’s asked me again the path to the game

My windows name don’t have non-alphanumeric but my account to access my computer have, but this the same i used to use on my previous computer

Can you open Windows PowerShell and execute this?

[Environment]::GetFolderPath("MyDocuments")

And paste the result here (you can select with your mouse while holding Shift).

ok i try

C:\Users\Meri-\OneDrive\ドキュメント

this is what i got

Yeah looks like that’s the problem.
Your documents folder is located in OneDrive and the path contains special characters… I don’t think the game can process those characters correctly.
Not sure yet how to fix it. I’d have to do some experiments on my side.

Do you remember by any chance what you did during your Windows installation? I think you used your Micosoft account to log in instead of creating a local account.
The error message says it’s Windows 10, is that correct?

ooh ok,

Yes on Windows 10, on my previous computer it was Windows 11

Looks like this might be a solution if you’re willing to disable backups for the Documents folder: sync - How to unlink my Documents folder from my OneDrive account? - Super User
After disabling the One Drive backups it should bring back your documents folder to the usual location.

I’m still going to try and fix it in the code, but it can take some time.

2 Likes

Ok i give a try thank you !

It works thank you so much i can finally enter the game !!

1 Like

This now should be properly fixed. When the game cannot write into the documents folder, it’s going to use the AppData folder instead.